Moqui with docker for multi-instance thing

https://www.moqui.org/m/docs/framework/Multi-instance+with+Docker

hello i have followed these instructions and setup things
but problem is that ,At DB Creation thing i got error and also at moqui server not connecting
and just my docker container is created and instance is runing successful

If any one setup this can you tell me what extra things i have to do because its not working as i expected

see that red marks db-not-existed , moqui-server not running
and on clicking DB CREATE i got error that root@localhost permission denied

1 Like

Is the error message you mentioned (“on clicking DB CREATE i got error that root@localhost permission denied”) from MySQL? It may be that the user in MySQL does not have permission to create databases. IIRC MySQL made some sort of default config change a while back that I ran into when working on something else, and this could be the same issue.

2 Likes

That test wouldn’t reveal much, leaves two questions: is Moqui setup to use the ‘root’ user? when you login with the root user are you able to create a database?

Either way, to get rubber on the road and make progress on something like this, the actual error would be very helpful… we need to know what generated the error and in which context, and the exact text of the error message because it’s too easy to lose important details in a summary of the error.

Hi @rohit, I apologize for the directness, but that question on StackOverflow is very difficult to pick apart. I would recommend going back to the basics of defining an issue:

  1. what did you do (sufficient to reproduce or at least understand the relevant context)
  2. what happened
  3. how is what happened different from what you expected

The only problem statement I can see in there is " all thing it did but still i can’t access my server which is working inside the container". More information about what you tried and exactly what happened, or as much as you know, and at different layers (browser, nginx-proxy logs, etc), would make it easier for others to see what might be going on.

I’d also recommend avoiding assumptions without good proof, like: “all containers are in same network of type bridge and this has to work”. A big part of what I do when helping people debug issues is question their assumptions because if they are stuck, the assumptions may be the reason they are stuck and not making progress understanding the issue (and understanding the issue is necessary before it is possible to discuss solutions).

Another thing that might be helpful is to look at the nginx-proxy docs to understand how it is configured and works, and step through each part to verify. That is the ‘back to basics’ strategy when you’re not sure what might be the issue.

To start with what I’m guessing is the issue: following a single request, do you see in the nginx-proxy container’s log, and in the moqui.local container’s log? What does does it look like in the browser’s network tool tab (or whatever you’re using to access the moqui server)? That information would be helpful for others, or might even help you see what the issue is on your own.

1 Like

Hi Rohit,

I have faced same issue , my issue get resolved with application run with root permissions and database user creation done before containers running and then use same user in databases connection .

yes mine issue is solved