Is there a way in Moqui framework to prevent specifc url from redirecting to Https?

Hello to every one, I call web service to return json file content, the url is ‘http://localhost:8080/eduforms/test.json’, but framework change url to ‘https://’ and because of the server is offline, server do not access to domain and because of this webservice always failed, is there a way to prevent only specific url to redirect to https?


  1. https is enabled in framework
  2. server is offline
  3. server do not have ping or telent to domain

If the webservice fails for a server, then you need another way to get into the server. If you enable http the server, it will not fix that problem completely. You probably want to ssh into the server, and make any changes that are required to actually fix the underlying webservice problem. For example, once you’ve sshed into it, you could just load a base moqui server and access it from there.

1 Like

Hi, michael
All we need to fix this problem is to set webapp_https_enabled property to false.
this property is not allow to redirect local webservice calls in server to https.
im sorry for bad explanation

1 Like