How to disable the elasticsearch?

In the Flutter frontend I am not using the elasticsearch. In production i am not starting the elastic search, which saves me about 1-2 Gb memory . Although i get some errors , my GrowERP Flutter frontend is working fine.

What is the best way to disable the elasticsearch altogether and get rid of the error messages in the log?

Thanks in advance for your suggestions,

Have you tried no-run-es?

Yes, it is mentioned at the Moqui Documentation page, but not mentioned at the java -jar moqui.war --help screen.

If you add this parameter no-run-es to the java -jar moqui.war command, it is mentioned in the startup log with:
Running Jetty server on port 8080 max threads 100 with args [{no-run-es=}]

however these messages still appear:
Error connecting to ElasticSearch cluster default at, try 1 of 20


Are you running Moqui on the client?

I use Flutter on the client, all source at GrowERP · GitHub

What are the error message?

Are you sure you don’t want to run elastic search? Elastic search is used for storing logs which are vital for discovering what is going on in the system. It’s also used for data documents.

If you don’t want to run elastic search I just wouldn’t install it on the server.